О сервисе Тарифы Требования Операторы Демо





1С конфигурация для отправки SMS

Скачать конфигурацию 1С

Конфигурация написана на 1С Предприятие 8.2 с поддержкой работы веб-клиента. Для работы конфигурации необходимо заполнить константы:

  •  ПользовательСМС – Ваш логин в систему;
  •  ПарольСМС – Ваш пароль в систему;
  •  ПодписьСМС – Ваш адрес отправителя, который был создан в личном кабинете.

Конфигурация позволяет:

  •  Отправлять смс контрагенту, номер которого записан в соответствующем реквизите (номер пишем в формате 380ХХХХХХХХХХ);
  •  Получать статусы отправленных смс.
&НаСервере
Функция ОтправитьСервер()
УспешнаяОтправка = Ложь;
ПараметрJSON = "{'username': '" + Константы.ПользовательСМС.Получить() + "'";
ПараметрJSON = ПараметрJSON + ",'password': '" + Константы.ПарольСМС.Получить() + "'";
ПараметрJSON = ПараметрJSON + ",'request_type': 'send_message'";
ПараметрJSON = ПараметрJSON + ",'destination_address': '" + Объект.Контрагент.НомерТелефона+ "'";
ПараметрJSON = ПараметрJSON + ",'message': '" + Объект.ТекстСМС+ "'";
ПараметрJSON = ПараметрJSON + ",'source_address': '" + Константы.ПодписьСМС.Получить() + "'";
ПараметрJSON = ПараметрJSON + ",flash:'0'}";

Попытка
WinHttp=Новый COMОбъект("WinHttp.WinHttpRequest.5.1");
WinHttp.Option(2,"Windows-1251");
WinHttp.Open("POST","http://api.avisosms.ru/sms/json/",0);
WinHttp.SetRequestHeader("Accept-Language", "ru");
WinHttp.SetRequestHeader("Accept-Charset","Windows-1251");
WinHttp.setRequestHeader("Content-Language", "ru");
WinHttp.setRequestHeader("Content-Charset", "Windows-1251");
WinHttp.setRequestHeader("Content-Type","application/x-www-form-urlencoded; charset=Windows-1251");
WinHttp.Send(ПараметрJSON);
ТекстОтвет = WinHttp.ResponseText();
Если Найти(ТекстОтвет, "OK_Operation_Completed") Тогда
УспешнаяОтправка = Истина;
КонецЕсли;
Исключение
Сообщить("Ошибка соединения:");
Сообщить(ОписаниеОшибки());
КонецПопытки;

//Запись отправленной смс в историю
Если УспешнаяОтправка Тогда
ПозицияКодаНачало = Найти(ТекстОтвет, "messageId") + СтрДлина("messageId")+3;
ПозицияКодаКонец = Найти(ТекстОтвет, "}");
КодСМС = Сред(ТекстОтвет, ПозицияКодаНачало, ПозицияКодаКонец-ПозицияКодаНачало-1);

СМСРассылка.ЗаписатьСМСВИсторию(Объект.Контрагент, Объект.ТекстСМС, КодСМС);
Иначе
Сообщить("Отправка смс не состоялась. Текст ошибки: " + ТекстОтвет);
КонецЕсли;
Возврат УспешнаяОтправка;
КонецФункции

Colored with dumpz.org

Сайт автора кода

Примеры кода

PHPPython,   Java,   Ruby on Rails,   Perl,   Delphi,   .NETC#,